CRM 2013 Mobile App not working externally when published via WAP

2017-12-04T09:54:33+00:00 February 26th, 2014|CRM|0 Comments

We had in issue recently when Publish CRM via WAP, that the CRM Mobile app did not work at all but normal access via a web browser worked with no issues at all.

When running the “Dynamics CRM” app remotely we were getting the following errors:

Mobile Client – oops unknown error

CRM Mobile App – Your server is not available or does not support this application

We found out the issue was that on the WAP server, we had the authentication set to ADFS Pre-auth and not set to pass through. The issue is that the Mobile App doesn’t understand ADFS pre-auth from WAP , so when the app tries to Pre-Auth it gets sent a 307 redirect from the WAP server which it doesn’t understand how to handle and bombs out.

To resolve this you have to do the following:

  • Deleted CRM Organization WAP application that uses “pre-auth”
  • Re-create WAP application using “Pass-Through” authentication
  • Run Get-WebApplicationProxyApplication
    | FT Name, ID
  • Make a note of the ID of the CRM organization application ID
  • Run Set-WebApplicationProxyApplication -ID EnterIDHere –DisableTranslateUrlInResponseHeaders

So your Config should look like the below:

Remote Access Management Console show Pass through Pre-Auth for CRM

PowerShell shows that TranslateUrlInResponseHeaders is disabled

After these changes , when the CRM App tries to authenticates the clients now get a 302 redirect which the Mobile App understands and all works perfectly J

 

 

Leave A Comment

like what you see? 

Sign-up to our newsletter and never miss out on the latest blogs, events and tech news from the world of risual
SUBSCRIBE!
Give it a try, you can unsubscribe anytime.